Jump to content

Workflow - Terrain scenes become offset from 'world' origin in editor


designleviathan
 Share

Go to solution Solved by Peter,

Recommended Posts

Hello

When I'm going through the workflow of setting up my 'full' terrain setup - I've noticed that the 'stamped terrain' (as in the terrain created by the terrain stamper not the preview) becomes offset from the "world origin".

Practically this means if i 'fit to world' with the terrain stamper - the next time I 'fit to world' with a biome it's offset from the 'original world origin'.

I am not translating the world at all. I suspect it has to do with the terrain scenes becoming unloaded and then loading in at a different origin in the editor space.

I'm hoping this is a simple workflow error I've made but I'd like to have everything 'fitting' into the same world-space from the same origins.

I am using pretty much stock Gaia everything.

hope this makes sense - happy to clarify

Link to comment
Share on other sites

This is showing the now-multiple-world-zones that happen without the terrain loaded - the one in the distance should be the only one and all terrain tiles should be contained within that one

Screenshot 2022-03-31 101816.png

Link to comment
Share on other sites

924009470_resizeScreenshot2022-03-31101910.thumb.png.3c5e6e4a36a658e9c594be72a75b1f35.pngThis is from after loading in the unloaded terrain tiles - you can see in the distance that the terrain tiles have 'escaped' the 'original world bounds'

Link to comment
Share on other sites

Posted (edited)

Unfortunately this has broken most of my biome masks and mountain stampers (which where specifically placed before).

 

How can I setup masks and stampers in the same absolute place every single time and avoid this 'origin shift'?

Edited by designleviathan
clarification
Link to comment
Share on other sites

I have double checked - on no tampers have i adjusted the default offsets

Link to comment
Share on other sites

STAMPERANDSETTINGS.thumb.png.66963943fe6ea309a5d5efc764c2d59d.png

'Original' stamper origin and 'offset' preview + offset terrain tiles (not all are loaded because they now fall outside of the stamper bounds)

Link to comment
Share on other sites

This happened using a local stamp as well fwiw which is which I switched to 'world space' hoping it would be 'absolute' in terms of positioning when loading and reloading.

Link to comment
Share on other sites

  • Solution

@designleviathan The first thing that comes to mind is the "Origin Shift" in the Gaia panel, could you please unfold that with the downward arrow to see if there is any shift values entered in here:

image.png

A bit more on what that does: It can happen for various reasons that Gaia takes a terrain tile and shifts it elsewhere, for example when the "Floating Point Fix" solution is active with terrain loading. Normally though it should do this only temporarily though and you (and especially the player) would not notice this happening.
You can however shift the origin by entering values in those fields. If you e.g. enter X=200, the whole terrain loading in Gaia should behave as if the entire world was shifted by 200 meters on the X axis. You normally would not need this feature unless you are running in floating point precision issues while editing the world, then you could shift the entire world around to make it so that you are editing closer to the origin at 0,0,0 to avoid any floating point issues.
I could imagine that maybe some process or some bug entered an offset there that then was never reset, and now your entire world is permanently shifted? If there is any values in there, putting it back to 0,0,0 should fix it.

Link to comment
Share on other sites

  • 4 weeks later...

@Peter sorry it took a while to get back on this one.

I think the first time i encountered this I was having a different unity (Possibly even PC) error with many non-core unity inspector / panels not updating so the origin shift settings were showing 0 which was confusing so I had kinda 'hacked' my way through it by repositioning things just to finish my burndown.

Ultimately I had started 'fresh' on that world setup because of a different issue made late while burning the midnight oil. (accidentally disabled a gaia component and it broke loading terrains)

In this new world project the 'offset' bug came back. This time around I 'took notes' on exactly when it came up and how to fix it.

  1. Your origin shift fix worked this time as the values were properly populated / updating
  2. Sample size of 1 - but this issue seems to come from adding multi-spawner biome controllers to your world.
    1. It seems that some of the spawners seemed to carry with them the original loading or positioning

 

Thats it - I'll close this off and mark your answer as the solution.

My only recommendation would be maybe to throw a line in the documentation about this specific behaviour so others like myself don't have flounder due to our naivete when you guys have given us the tools to fix it (provided unity aint misbehaving!)

Link to comment
Share on other sites

FWIW it seems to always offset stuff by 640 by 640 for some reason

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...