Jump to content

3.2.4 Gaia Pro from Asset store script errors on import

Mike Wuetherick
Go to solution Solved by Mike Wuetherick,

Recommended Posts

Just loaded up the latest Gaia Pro 3.2.4 from the asset store and it explodes with a bunch of errors about the new time of day system.





Link to comment
Share on other sites

Hello @Mike Wuetherick, those errors are a bit concerning for us - we did have an issue in the previous version 3.2.3 where you would get those errors under specific conditions on import, the newer version 3.2.4 was supposed to fix that. When submitting to the asset store we tested various unity versions to make sure that this has been fixed. 
I just did another test install with the asset store version in Unity 2021.3.0f, and that seems to work for me. I will do another in the built-in pipeline in 2022.1.

We did get another report from an user that they would get those errors on import, there the issue seems to be that they are still receiving the earlier version 3.2.3 through the package manager. This was confirmed by looking at the file size in the asset store download cache. Could you please check in the asset store download cache as well to rule out it is the same issue? The asset store cache can be found in the user data directory on your machine, the screenshot shows the correct file size for version 3.2.4:

If you do have a different file size, could you please try to delete and redownload the package? If the file size is correct, could you please share your unity editor version and the render pipeline used so we can try to reproduce the issue in the same constellation?

Link to comment
Share on other sites

  • Solution

It seems that the scripting defines didn't get created when the package was imported for whatever reason - adding them in fixed it

Link to comment
Share on other sites

however when I open the gaia manager and try to create a terrain now I don't seem to get the stamper & other tools? I can see the gaia manager but the stamper etc don't open automatically and the only thing added to the scene is the Gata Session Manager and a few things under the Gaia Runtime parent...

very strange, I've uninstalled and reinstalled Gaia a few times today, never had this issue before

Doesn't seem like it set the scene up properly?


Link to comment
Share on other sites

Hi @Mike Wuetherick, thanks for coming back with the solution. Do you remember which defines you had at the point of the intstallation, and which ones you had to add? I know there can be issues if the scripting defines of Gaia are only partially there (e.g. if there was a Gaia install in the project before, and only some of the scripting defines were removed when removing Gaia), but normally in the two usual scenarios you should not run into such a situation:
- On a fresh install, no defines should be there and they should be added after install
- On an update install, all required defines should be there already so that the code should compile in its final state right away after install. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...