Jump to content

Dividebyzero Error


klarkit
 Share

Go to solution Solved by klarkit,

Recommended Posts

Getting a dividebyzero error in a clean project with only Gaia Pro 2021 installed. This is Unity version 2020.3.28f1 LTS.

Tried downloading Gaia clean and starting over but getting same error.

Link to comment
Share on other sites

I get the same error when browsing for a terrain layer or terrain tree. It's probably related to Unity as it can appear without Gaia installed

Link to comment
Share on other sites

I was thinking the same thing. So now I am going to try a fresh Unity install and see what happens.

Thanks for the reply.

Link to comment
Share on other sites

If you run into this error again, could you please provide the full error message from the lower part of the console window? You can copy and paste it in here, or make a screenshot of it. This is a generic error that just says somewhere in the code a situation is created where a value is divided by zero which cannot be computed, but as Matias Gesche pointed out this might be something that comes out of unity itself rather than Gaia. With the full error message I might be able to tell some more.

Link to comment
Share on other sites

  • Solution

I upgraded to 2021 and the error has gone away. It had something to do with my 2020 version of Unity. But if it happens again I will post the full error here.

Thank you for the reply.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
On 3/20/2022 at 10:57 PM, Peter said:

If you run into this error again, could you please provide the full error message from the lower part of the console window? You can copy and paste it in here, or make a screenshot of it. This is a generic error that just says somewhere in the code a situation is created where a value is divided by zero which cannot be computed, but as Matias Gesche pointed out this might be something that comes out of unity itself rather than Gaia. With the full error message I might be able to tell some more.

Sorry to revive this topic, but the error drives me nuts. Here is the screenshot of the error:

spacer.png

Unfortunately I can't upgrade to 2021 as some of my assets are not supported. 

Yes I think is Unity, but if someone knows a way to get rid of it would be great

Link to comment
Share on other sites

You may need to contact Unity support or check the Unity forums regarding this. 

Link to comment
Share on other sites

@Matmalm I looked at the error and from the lower part of the error message it looks like this error originates from the terrain inspector itself, and most likely has nothing to do with Gaia. As Bryan pointed out you would need to contact Unity. If you can, try to update to the highest 2020 release that is available for you as this might have the bug fixed.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...