Jump to content

Grass won't spawn right.


Gettinng IT up
 Share

Recommended Posts

Hey do you know what this error is? I can't seem to spawn my grass quite right anymore for some reason...unknown.png

This is what it's spawning.
unknown.png

And this i some of my grass settings.
image.thumb.png.40b21a2c87740f85502afceea1500e50.png

i've even being trying to make some default types work but this is the only thing that seems to be happening. I have two grass textures for the terrain, i would assume that might be a part of the issue?

Link to comment
Share on other sites

Also i get this warning when i try to use the Gaias visualize on individual spawner's
image.png.8016b0a71c04d31351906a97caa7662e.png

But i don't know why it's not working because it's set to use URP and i'm using URP...... so can't see what i'm trying to spawn.

Link to comment
Share on other sites

1 hour ago, Gettinng IT up said:

Also i get this warning when i try to use the Gaias visualize on individual spawner's
image.png.8016b0a71c04d31351906a97caa7662e.png

But i don't know why it's not working because it's set to use URP and i'm using URP...... so can't see what i'm trying to spawn.

Have you gone to Gaia Manager - Setup- Change render pipeline to URP and then install shaders? 

Link to comment
Share on other sites

Hello, what type of source data does your grass settings have? You can find this out by hitting the drop down button under PW_Grass_Patch_01LOD0:

image.png.409315cb43217609d892d99154aeb128.png 

Could you also confirm if there is a grass prefab listed in the Unity Terrain's Detail Section? 

image.png.3306f798dc0cd11a6564d7608071f05c.png

 

As for the visualizer, you may want to check under Edit -> Project Settings -> Graphics to see if a PWS render pipeline asset has been added. image.png.96cf282ef9a95aa761f0373d625ce425.png

Also check under the Quality settings as well:image.png.ef91aa79168d7f7bccabb52e8e1f62db.png

Link to comment
Share on other sites

I already did that Render pipeline stuff. i don't know why it's doing that. this is a pic of the grass.image.thumb.png.f2ba01b7c4639c9896508f5626136d7a.png
it is spawning some of the grass but not the amount it's supposed to.
is there something wrong with the flora settings?
image.png.071b929bba2289cba3f88a512930253d.png
I was wondering if because i have two grass Terrain textures that that could be what's stopping it...

Link to comment
Share on other sites

i also just found it spawning grass under the water. Which i know it's not supposed to....image.thumb.png.4e4814d2f4b1c7a84195bb06b0c5566b.png

Should i try updating Gaia pro 2021? it won't over right my terrain data right?

Link to comment
Share on other sites

I think i figured something out. i think the collision mask had the wrong layer set up.(still not sure why the Gizmos wont work)
image.png.d1750c9d76d23fd85e1588aee929e137.png

Link to comment
Share on other sites

I fixed it. i had imported a package that changed the Layers and that massed up the collision mask.  Also not sure why but the Gizmos are fixed now...wth. lol

Link to comment
Share on other sites

17 hours ago, Gettinng IT up said:

i had imported a package that changed the Layers and that massed up the collision mask.

You have to love it. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Unity 3D World & Game Creation Tools - Canopy - Procedural Worlds? Tell a friend!
  • Interesting Articles

    1. 0

      Different layers are being combined together.

    2. 42

      GeNa Pro City Generator

    3. 1

      World Creator + Gaia

    4. 1

      Gena decorator??

    5. 1

      Objects spawning at unexpected position in segmented scene.

×
×
  • Create New...