Jump to content

Floating Point Fix


Mattis89
 Share

Recommended Posts

This floating point fix seems a bit brutal... You can really notice when the world is shifting to 0,0,0.. I have a character, camera and a car. the character have the terrain loading component and floating fix .. camera & car have the floating point fix member component... is that right?

Link to comment
Share on other sites

On 2/19/2022 at 6:50 AM, Mattis89 said:

This floating point fix seems a bit brutal... You can really notice when the world is shifting to 0,0,0.. I have a character, camera and a car. the character have the terrain loading component and floating fix .. camera & car have the floating point fix member component... is that right?

You can try adjusting the floating point fix threshold, the thing to note about the threshold is that when the player exceeds this the world origin will shift. 

Also you only need the floating point fix on the car / player not the camera. 

Link to comment
Share on other sites

Okay , I see..  I get a floating point error if I don't add it to the camera.. and If it's not added to the camera it won't start to load in any scenes... And also If I don't have both Gaia scene player component and the terrain loader component the terrain won't load in .. I'm using Gaia scene player component on my character because I want the culling.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...