Jump to content

Gaia Pro 2021 Error CS0117 for PerlinNoise and FbmFractalType


TheSheepdog
 Share

Go to solution Solved by Peter,

Recommended Posts

Hello all! I'm not that good at C# and I have managed to fix some C# issues on other packages but not this one. I have been using Gaia for a few years now and have never had any issues installing or using Gaia until yesterday. I had the issue on a project that I had been working on with Gaia already installed and had been using it fine then out of the blue, these errors. I opened a fresh project and had the same issue.

Everything installs (unpacks) fine. However, after my terrain is created using World Designer, I get PerlinNoise and FbmFractalType errors. 

Assets\Procedural Worlds\Gaia\Scripts\Unity\Terrain Tools\Noise\NoiseSettings.cs(135,50): error CS0117: 'PerlinNoise' does not contain a definition for 'instance'

Assets\Procedural Worlds\Gaia\Scripts\Unity\Terrain Tools\Noise\NoiseSettings.cs(136,55): error CS0117: 'FbmFractalType' does not contain a definition for 'instance'

Assets\Procedural Worlds\Gaia\Scripts\Unity\Terrain Tools\Noise\NoiseSettings.cs(137,52): error CS0117: 'PerlinNoise' does not contain a definition for 'instance'

Assets\Procedural Worlds\Gaia\Scripts\Unity\Terrain Tools\Noise\NoiseSettings.cs(138,57): error CS0117: 'FbmFractalType' does not contain a definition for 'instance'

Unity version 2021.1.3f1 3D (Core)

Gaia Pro 3.1.4-c5

I have also tried Unity 2019.4.2f1 and nothing changed. I changed from Perlin to Ridge and got the same results and now I am just stuck. I'm sure it's a simple fix for someone but scanning the C#, I don't see what I could possibly change to make a difference.

Maintenance in the Gaia manager didn't find anything either. So, what did I break?

NoiseSettings.cs

Link to comment
Share on other sites

Can you please try it in the latest 2020.3 LTS? 2019.4 is not supported, the previous mentioned LTS is the minimum requirement. 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

On 1/23/2022 at 2:36 PM, MiTschMR said:

Can you please try it in the latest 2020.3 LTS? 2019.4 is not supported, the previous mentioned LTS is the minimum requirement. 

That did the trick. Thank you! 

Had I bothered to read the render and pipeline compatibility on the Gaia asset store page, I wouldn't have been here. I will say this, going back to other projects I had been working on (Ultimate Survival), I noticed that I got the same errors. After deleting US from the project, the Gaia errors went away.

Thanks again @MiTschMR

Link to comment
Share on other sites

These errors mysteriously showed back up while using 2020.3.0f1. I am back where I started.

Link to comment
Share on other sites

The initial version of a new Unity release branch (even if it is an LTS) is most likely contaminated with bugs that have been fixed in the months after release.
 

On which version have you tried it before, because apparently it had been "fixed"?

  • Like 1
Link to comment
Share on other sites

  • Solution

@TheSheepdog I had a look at these errors, and I have one suspicion: You mentioned that the errors went away when you removed "Ultimate Survival" from your project - is "Ultimate Survival" an asset or anything that would contain its own code? I assume that in its scripts it might have a definition for "ScriptableSingleton" somewhere in its code that overrides the "Scriptable Singleton" of Unity itself.

This might be difficult to understand without a programming background, but the error messages from Gaia that you are seeing basically say: "Hey, this field 'instance' that you are using here does not exist". When I dig down into this error this field 'instance' should be defined in Unity's "ScriptableSingleton", but I assume that there is something that overrides that definition of "ScriptableSingleton", which then in turn leads to those errors.

If my theory is right, you should be able to fix this by doing the following:
Open your Code Editor to open the file "NoiseType.cs". In line 108 change "ScriptableSingleton" to "UnityEditor.ScriptableSingleton" and save the file.

image.png

Note that if I'm correct this is not a Gaia bug - while you can fix it by editing a Gaia script this would rather be bad style / behavior by the other script that overrides the definition of "ScriptableSingleton", that is something you should not do as a developer, as that would create issues for anyone trying to use the default "ScriptableSingleton" from Unity in their projects.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Using Gaia Pro 2021 fixed my issue. I always use Gaia Pro 2021 and have no issued and was confused when I did. I didn't realize that I wasn't using GP 2021. Thank all of you for your help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...