Jump to content

Having trouble with GTS


Recommended Posts

Hello, I've been working on a game which has gts terrain shader. However I've got 2 issues, first one is in Editor, you can see black areas, second one is in Runtime which is after build. I tried everything I've already read. Delete scene files, do that, do it etc... I've even tried in URP and SRP, both of them are same. Need help or update asap...

This is in the editor and play mode : https://ibb.co/g3pFZZt

This one is in build : https://ibb.co/YffNTpK



Link to comment
Share on other sites

Hi @evrenacg,

Sorry that this behaviour is occuring in your scene. For some added context, what version of Unity are you using, what build target is the project set to, and which version of GTS are you on?

We released an update a day ago which addressed some saving scenarios with multi terrain setups, but this case may be related to something else. 

Also, to debug this a little further, can you navigate to where the GTS material is located (select the terrain, then find the material slot), and check whilst playing in the editor if the Control0 / Control1, and _SplatmapIndex textures are correctly assigned (i.e. do any of them show up as 'none')? If you are only using 4 terrain layers, then it is expected for the Control1 to be none.



Link to comment
Share on other sites

Hi @evrenacg,

Since this last post we have released another update for GTS which includes a couple of use case handling fixes, as well as implements a 'Regenerate Data' button to rebuild the connections for the GTS material. 



Link to comment
Share on other sites

Hey @Isaac thanks for reply. Sorry for late answer, had to work on my job...

Well I've tried latest version which is "1.0.13", It's working as same as in Editor mode now. Not like https://ibb.co/YffNTpK | but this  https://ibb.co/g3pFZZt

When I refresh GTS, It sets scene dirty and seems ok but when I save the scene It backs to earlier squared buggy version 😕

Well, there is only one terrain in the scene, Unity version is 2022.2.13 ...

I did what you recommended before, thats not fixed issues.

Link to comment
Share on other sites

Hi @evrenacg,

Sorry that this issue is still persisting. I may need some more context on the material setup.

When you select the terrain material, and select one of the control textures, does the location point to the same location as where the terrain material is stored? 


Sometimes the location can point to the terrain data object instead, such as pictured below:


Or it points to a render texture, which then gets reset upon saving. 

Some further questions:

  1. Have you tried pressing the 'Regenerate Data' option?
  2. Also, what is the project build target (i.e. windows, android, etc)?
  3. In the project settings Quality tab, what resolution is the Texture Quality option set to?
Link to comment
Share on other sites

This is what I see when scene is dirty: spacer.png

Then this is after I saved the scene: spacer.png


This is also when material is selected:




1 - Yes I did regenerate a few times.

2 - Build target is Windows, Intel 64.

3 - Full Resolution selected for High Quality.


However I tried other quality options and Built-in and URP pipelines too... Thanks in advance.

Link to comment
Share on other sites


Apart from checking before and after saving on the terrain material to see if any textures loose their reference / point to a different location, as pictured below:


I am struggling to replicate the behaviour, in my tests the saving doesn't seem to produce this squared effect. 

To investigate this further, is there any chance I could get access to your scene, either through a brand new project where this error occurs, or a stripped out version of the project (you can Private Message me to keep the file from public use)? I need to check if it's project setting related, if it relates to a specific scene setup, or if its a Unity version thing. 

If not, maybe providing a step by step list (from creating a new project to applying the material) may help me see it starts occuring. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...