Jump to content

Water System Mode not working

Go to solution Solved by Bryan,

Recommended Posts

Hi there. I've tested your tool (Gaia ML) on my Mac Studio M1, Monterey. I use the silicon version of Unity (, 10f1 and 11f1). Most of it worked like a charm and out of the box. Thats great!


But when I enable "Water System Mode" and set it to Gaia I will get weird artifacts. When I set the mode (to None or Third) I cannot see any water but the artifacts are gone.


Do I need some additional Packages?



Link to comment
Share on other sites

  • Solution

So this is an issue with Mac to fix this please do the following: 
Open the water shader file in Assets\Procedural Worlds\Gaia\Shaders\PW General\PW_Water.shaderIn line 61, remove the two leading slashes "//" to comment in the command "ZWrite Off".

  • Thanks 1
Link to comment
Share on other sites

Wonderful. This helped and gave me a beautiful beach view with moving water. Thanks for your help!


In case anyone else has this error: It was line 63 on my current setup as of 03.10.2022.



Link to comment
Share on other sites

  • Bryan locked this topic
This topic is now closed to further replies.
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...