Jump to content

GeNa spawn to texture doesn't seem to work for me


Smugmushroom

Recommended Posts

Hi guys,

So basically, I am trying to get GeNa to only spawn trees to my woodland textures.  
Terrains made with Gaia, textures are being handled by CTS.
I can select the texture I want in the decorator, but GeNa refuses to spawn anything anywhere with the texture selected.
What am I missing please?

 

TIA

Link to comment
Share on other sites

EDIT - to add...

 

Visualizer shows green across texture borders and single click spawning creates the light probes but doesn't spawn the game object.

Link to comment
Share on other sites

  • 4 months later...

I'm having this same issue.

 

GeNa Spawner -> Spawn Criteria -> Check Textures

 

Trees still spawn on textures that are not selected in the Check Textures list.

Link to comment
Share on other sites

  • 2 months later...

I'm having the same issue.  When spawning a tree, I want to spawn it to grass but not to sand/dirt etc.  I check the "Check Textures" button and a type of grass appeared there the first time but I still couldn't spawn trees to any grass anywhere.  Oddly, later after trying to tweak some settings to see if I missed something, I went back and tried "Check Textures" again but this time nothing at all showed up on the drop down menu.  

 

If it's a bug I'll stop for now and save time by working on something else.  Otherwise I'm not sure what is happening.  I tried to follow along the "Deep Dive" tutorial that talks about this but nothing seems to work that is mentioned in the tutorial.

Link to comment
Share on other sites

One more thing here.  I got the Check Texture to work but I had to make the tweaks in a certain order.  I started a new scene and I think I went to Check Texture BEFORE I adjusted any other spawn criteria and it worked.  I cannot duplicate the error now so it may simply be an order of tweaking thing (still a bug?) but there may be a workaround.  

Link to comment
Share on other sites

  • 1 year later...

well 2 years later, I don't think they fixed this I have tried everything, I can't get GeNa to spawn on texture, no matter what I do ... it always either spawns everywhere if I lower texture strength to like 0.3 or nowhere  if I increase the strenght ... I tried playing with all possible random settings  but nothing works ... please if you found how please tell me

 

P.S my terrain is made with unity and textured in Unity not Gaia would that cause the problem?

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...