Jump to content

World Designer shows no terrain


Ricky Taylor
 Share

Recommended Posts

I've followed the tutorial to the point of creating a world designer, but it never spawns any terrain. I've tried importing Gaia into an empty HDRP project and it behaves the same there too.

If I press "Generate World" it exports flat terrain pieces, which I can adjust with the built-in Unity tools fine.

I've tried Unity 2020.3.32f1 and 2021.3.0f1.

Is there anything else I can try to get it working?

1900679343_Screenshotfrom2022-04-1410-30-27.thumb.png.a1d5f4c68b8fc474e9f549cb83eb76c3.png

Link to comment
Share on other sites

I've managed to partially work around this by changing a lot of code in Gaia pertaining to reading/writing the heightmap. It seems that Gaia assumes that heightmaps are stored as a single-channel texture, which isn't always the case. In my case, I'm using Vulkan in the editor.

For now, I've just converted between the unity packed heightmaps to a single-channel texture around every API call to TerrainData and removed all calls to (Pack|Unpack)Heightmap from the Gaia shaders.

Additionally, the copy of Unity's Terrain Tools packaged with Gaia conflicts with the official version if also installed, resulting in their shaders being used by Gaia - and they have been modified.

Is there any chance for a fix? I'm happy to provide the changes I made to get this far.

Link to comment
Share on other sites

We are looking into this. 

This should be correct, but you should see the previsualization of the terrain first. 
Have you tried switching to metal? 

You can switch to metal, create your world and then switch back to Vulkan. 
Vulkan doesnt handle compute shaders, which is how we handle the preview. 




 

Link to comment
Share on other sites

As the risk of double responding too much: I'm on Linux so I have to use Vulkan if I'm using HDRP.

The modifications I have locally make the preview work along with terrain export but they're fairly invasive. (I'm pretty sure I've missed some cases too but it's enough for me to work with for now!)

  • Like 1
Link to comment
Share on other sites

@Ricky Taylor Sorry you were running in so many issues with Linux - we have unfortunately only very few Linux users (no exact numbers available but I would estimate below 1%) so issues are less likely to be discovered there. Thanks for providing some insights what your issues were and how you fixed them, this helps us to provide fixes for future Linux users.

The assumption that only the red color channel is relevant to the heightmap information and the pack / unpack heightmap functions are not exclusive to Gaia, we took that from unity examples and the terrain tools package, so it is strange to see that this gave you issues in Linux. It would be interesting to see what your fixes were, do you mind to provide your folders
Gaia\Scripts
Gaia\Shaders
Gaia\Gaia Pro\Scripts
Gaia\Gaia Pro\Shaders
in a .zip or .unitypackage so we can make a comparison against default Gaia? I will send you an OneDrive folder for file upload in a moment via DM.

Another oddity is the issues with the terrain tools package - as you found out already, some parts of Gaia are derived from shaders found in the package, however there should normally be no conflicts between the two, all our files should have a different identifier in their .meta files, so they should not be overwritten when installing the two tools in the same project. I just did a test install with both tools in 2021.3.0f and did not run into any issues. Could you please name an example where you got a file conflict, so we can double check?

Link to comment
Share on other sites

I've been using Gaia under Linux (Ubuntu/Vulkan on NVidia) too and had a similar problem under 19.4.? but it resolved itself when I ditched CTS in favor of MicroSplat.  Since then I haven't had any trouble with the previz either.   But I'm using built-in, not HDRP.

Link to comment
Share on other sites

Have the same issue on Arch Linux. The process of world creation in OpenGL URP is no problem, if I do it in Vulkan tho, the terrain does not show in the preview. Neither with Built-in, URP or HDRP on Vulkan.

I will built the terrain on built-in OpenGL and then upgrade the projct to HDRP and Vulkan. Should be no problem, except you want to build a project directly in HDRP, then you can only choose Vulkan as your API.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...