Jump to content

Bright trees at night


Loran75
 Share

Go to solution Solved by Peter,

Recommended Posts

Hi,

I'm Using PWS Polygon Nature with HDRP.

It works well with Day Lighting Profile but at Night, distant trees are very bright. 

image.thumb.png.bc8a151fc2c134fd5f711e18926fa503.png

Link to comment
Share on other sites

  • Solution

@Loran75
Hi, I checked, and I was able to reproduce the issue. This has to do with the shaders used in HDRP, they are using Emission on the billboard stage of the trees (the lowest level of detail that is displayed when the tree is far away). This makes it look like they are "emitting light" in the dark.
I assume it was done this way to work around issues with rendering billboards in HDRP during daytime, I know from other situations where it can be difficult to get the color of the billboard stage to match with the actual tree model, however the effect it has on the scene during day time seems to be minimal.

What you can do to fix this for now for your night scene is the following:

1. Go through the materials in these two folders:

image.png

2. For each folder, select all the materials and adjust the Emissive Color to be full black instead. Keep an eye on the scene view to and you should see that the trees stop shining in the distance:

image.png

When I check back with daytime lighting, there seems to be no visual downside for me to turn off the emissive color this way. We need to review this and unless there is some issue that I'm not aware of we might make this the standard setting then.

Link to comment
Share on other sites

I also ran into this problem, it does look like you are possibly having a different issue but here is my 2 cents anyways 🙂

So when I auto converted materials it put them all HDRP/Lit which adds a weird backgroundish light, had to manually change the shader to HDRP/Unlit

Link to comment
Share on other sites

Thank you @Peter, I would never have found it on my own!

Your detailed explanations are very clear.

I will continue to work on my night scene and let you know.  

 

Link to comment
Share on other sites

Thank you @GryffnGaming, it’s a smart workaround. 
Unlit shaders are not affected by light, but they are very fast. I’ll consider this solution for the distant objects. 
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...