Jump to content

Moon Light is causing my build to fail


Sorra the Orc
 Share

Recommended Posts

I can't build with Gaia (Unity 2021.2.9f1). The error is:

 

Assertion failed on expression: 'go.IsActive()'
UnityEngine.StackTraceUtility:ExtractStackTrace ()
Gaia.GaiaUtils:GetMainMoonLight (bool) (at Assets/Procedural Worlds/Gaia/Scripts/Utils/GaiaUtils.cs:2121)
Gaia.ProceduralWorldsGlobalWeather:GetCurrentSettings () (at Assets/Procedural Worlds/Gaia/Gaia Pro/Weather/VFX/Scripts/ProceduralWorldsGlobalWeather.cs:6871)
Gaia.ProceduralWorldsGlobalWeather:DeinitializePostFX () (at Assets/Procedural Worlds/Gaia/Gaia Pro/Weather/VFX/Scripts/ProceduralWorldsGlobalWeather.cs:2493)
Gaia.ProceduralWorldsGlobalWeather:OnDisable () (at Assets/Procedural Worlds/Gaia/Gaia Pro/Weather/VFX/Scripts/ProceduralWorldsGlobalWeather.cs:1783)
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)


The offending line is:

GameObject moonObject = GameObject.Find("Moon Light");

Not sure where that "go.IsActive()" is coming from. There is a Moon Light object in the scene.

If I delete the Moon Light object in order to let the code progress and create one at runtime I get:

 

Some objects were not cleaned up when closing the scene. (Did you spawn new GameObjects from OnDestroy?)
The following scene GameObjects were found:
Moon Light

This Moon Light object is left behind and now I'm back to the beginning again.

Link to comment
Share on other sites

What render pipeline are you using? And was you using the PW Sky or one of the static lighting profiles?

Link to comment
Share on other sites

On 2/4/2022 at 2:20 AM, Josh said:

What render pipeline are you using? And was you using the PW Sky or one of the static lighting profiles?

It is URP and PW Sky.

Link to comment
Share on other sites

4 hours ago, Sorra the Orc said:

It is URP and PW Sky.

Thanks will look into this issue for you. Was there anythign special to re-produce the issue or simply create a scene, add runtime with PW Sky and build?

Link to comment
Share on other sites

17 hours ago, Josh said:

Thanks will look into this issue for you. Was there anythign special to re-produce the issue or simply create a scene, add runtime with PW Sky and build?

I'm not aware of anything special. That said if this were happening in every case I'm sure it would have been reported before. Like all active projects I am doing stuff so it may need some effort to reproduce. I'm about to try another build so I'll be sure to gather more data about workarounds if I can.

 

9 hours ago, Josh said:

@Sorra the Orc Have you tried the 3.2.0 to see if you still get this issue?

 

I have not tried upgrading. This is an active project with a tight deadline so I have no plan to upgrade. I don't see anything in the release notes that make me think this has been addressed. 

Link to comment
Share on other sites

I've not experienced this for the last few builds. The only thing I can think of that has changed, other than I've been working on the project so made loads of changes (helpful, I know). Is that I removed GeNa from the project (as it was causing other problems that I can't recall now). I need to put it back in again soon so I'll report back if there's anything useful to know.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Unity 3D World & Game Creation Tools - Canopy - Procedural Worlds? Tell a friend!
  • Interesting Articles

    1. 2

      I'm getting tired of doing islands and craters

    2. 2

      I'm getting tired of doing islands and craters

    3. 1

      Problems with latest Gaia Update

    4. 1

      Adding shoreline or waterline effects, beaches, river banks, etc.

    5. 1

      Just upgraded my Canopy to Pro

×
×
  • Create New...