Jump to content

GeNa PRO doesn't work when used alongside Gaia Pro (unity 2022.0b2)


Ruchir Raj
 Share

Go to solution Solved by Ruchir Raj,

Recommended Posts

When I just have GaiaPro installed everything works fine but when I install GenaPro as well, I get this error in my console:

image.thumb.png.f17d6a8f25b18602bc0e692b7d03227e.png

Also, unity's memory utilization just goes really high (something like 90-95%), this sometime makes my whole system crash.

I get this error when I select the "World Designer" gameObject 

image.png.b045e2f36b9ad219dc477783be25a9db.png

The preview and other don't work either.
Because of this I haven't really been able to use GeNa till now. ☹️

Any help is appreciated 

Link to comment
Share on other sites

Is there a specific reason you are using a beta version of Unity that is not officially supported by PW?

Link to comment
Share on other sites

Yes, there are some new HDRP features that I have been using that require me to pull from unity's git repo, so I have to use the latest version for now 

Link to comment
Share on other sites

I guess because of some API changes (you can see them in the error message, gena cannot reference one of the experimental terrain APIs) it doesn’t work.

Link to comment
Share on other sites

Yeah, there were API changes in Unity a while back and this is actually a known issue.

Please use the solution on this Forum post: 

 

Link to comment
Share on other sites

oh its terrain tools that does that ? I wondered why i get that error in some projects but not others.

 

Link to comment
Share on other sites

5 hours ago, Manny said:

Yeah, there were API changes in Unity a while back and this is actually a known issue.

Please use the solution on this Forum post: 

 

I don't get the popup for updaitng the dll(s)

Link to comment
Share on other sites

I get this error when I reimport 

image.png.92725fb1497e41f5d9faccef48820568.png

 

looks like the APIs are out of the experimental section now

Edited by Ruchir Raj
Link to comment
Share on other sites

As a general rule we do not support Unity beta's, as they are usually pretty buggy.

How have you found Unity 2022 so far?

Link to comment
Share on other sites

4 hours ago, Adam said:

As a general rule we do not support Unity beta's, as they are usually pretty buggy.

How have you found Unity 2022 so far?

For the parts that I interact with, 2022 has been quite stable so far actually. 🤔 

 

Is there any quick fix I could do for this situation? Otherwise I'll have to wait for quite some time before they release the stable tech version 😞

Link to comment
Share on other sites

12 minutes ago, Ruchir Raj said:

Is there any quick fix I could do for this situation?

Unfortunately not - we have not prepared GeNa yet for this version. From our past experience, all work that we do in this regard can become moot if the beta changes again during development. Another problem is that there can be bugs in unity itself that are then wrongly attributed to us - we can then put hours of work into analysis, only to find out that it seems to be a beta issue.

What you could consider is doing the terrain / level design work in 2021.2 and then export the result over into the 2022 beta, if you need any of the beta features for your development.

Link to comment
Share on other sites

  • Solution

Okay well got it to work finally.

For someone facing the problem in the future:

  • Just import the package in unity 2021.2 and let it run API upgrader, then simply copy the updated GeNa folder to 2022.1 project.

I was surprised that this actually worked. 😁

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...