Jump to content

No Trees with Impostor Terrains


Recommended Posts

I used the preset 04 Create impostors, Convert Trees to GOs is true but no trees appear on Impostor terrains. 

Link to comment
Share on other sites

Can you please tell me what Unity version you are using? 
What Gaia version are you using? 
Which trees are you using, are they one of the preset biomes or your own? 

I just ran a test and its working for me. 

Link to comment
Share on other sites

Unity: 2021.3.24f1
Gaia Pro 3.3.0-c5

I am using both types of trees, Procedural World trees and other trees.

Link to comment
Share on other sites

I upgraded to Gaia Pro: 3.3.6 -c5 and still no trees on Impostor terrains. Am I supposed to delete the old Impostor terrains first?

Link to comment
Share on other sites

What render pipeline are you using? 

Do you have the trees and grass on the original terrain before making imposters? 
If so this is when I would see the trees get added. 

Otherwise, you could use something like GeNa Pro to spawn them on the imposters if you really wanted to. 

Link to comment
Share on other sites

Im using HDRP

I do have trees and grass on the original terrains.
All of my terrains are setup with grass trees and objects.

Do I run the game in play mode before generating the Impostors?

Link to comment
Share on other sites

You shouldn't no. 

Can you create a new scene and will it produce the same results? 
I have tested again and I cant get that to happen. 


Link to comment
Share on other sites

I tried other Scenes in the same project but still no trees.
How does it read the tree data? Maybe that data is corrupt.

Link to comment
Share on other sites

I believe it reads the Collider data. 

In my test I created a new project. 
Created the terrain, and then spawn the biome. 
Then went into the Gaia Manager - Advanced - Tool- Terrain Mesh Exporter. 
Then I selected to convert the terrain into a mesh terrain and add objects. 
From there it created the mesh terrain and added the trees. 
It also could be that version you have is corrupted or the project is corrupted in some way. 
Can you please check a new project and see if thats it? 
You could also see if you have an update for Gaia Pro 2021 and update the asset as well. 

Link to comment
Share on other sites

I feel as this works best with the built-in pipeline.

With HDRP, the terrain colors are not close when using Texture Bake Method: Base Map Export.

When I try Texture Bake Method: Orthographic Bake, the colors are correct but it bakes in the unrendered white grass.

Link to comment
Share on other sites

4 hours ago, Diggidy said:

Could HDRP also be the cause of why its not creating impostor terrains properly? 


Not really because the tests that I ran was in HDRP and builtin. 

I will try and do more digging. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...