Jump to content

Generating terrain causes CTD

Go to solution Solved by Peter,

Recommended Posts

Obtained 30 stack frames
0x00007ff61e7f86a8 (Unity) TypeTreeQueries::HashTypeTree
0x00007ff61e7ed2be (Unity) SerializedFile::WriteObject
0x00007ff61e7d7f57 (Unity) PersistentManager::WriteFile
0x00007ff61e7d9c6f (Unity) PersistentManager::WriteFile
0x00007ff61f5a0bb8 (Unity) WriteObjectsToDiskThreadSafe
0x00007ff61fbaf25c (Unity) CreateSerializedAssetV2
0x00007ff61fb49855 (Unity) CreateSerializedAssetV2
0x00007ff61fab556e (Unity) AssetDatabase::CreateSerializedAsset
0x00007ff61dfddbd9 (Unity) AssetDatabaseBindings::CreateAsset
0x00007ff61dda58bd (Unity) AssetDatabase_CUSTOM_CreateAsset
0x000001e75bde5c25 (Mono JIT Code) (wrapper managed-to-native) UnityEditor.AssetDatabase:CreateAsset (UnityEngine.Object,string)
0x000001e75bdf5b23 (Mono JIT Code) Gaia.GaiaSessionManager:CreateTile (int,int,Gaia.WorldCreationSettings,UnityEngine.Terrain[,]&,UnityEngine.TerrainLayer[],UnityEngine.DetailPrototype[],UnityEngine.TreePrototype[]) (at C:/Users/peter/Documents/Unity Projects/Test/Assets/Procedural Worlds/Gaia/Scripts/SessionSystem/GaiaSessionManager.cs:3293)
0x000001e75bde7d0b (Mono JIT Code) Gaia.GaiaSessionManager/<ExecuteCreateWorld>d__172:MoveNext () (at C:/Users/peter/Documents/Unity Projects/Test/Assets/Procedural Worlds/Gaia/Scripts/SessionSystem/GaiaSessionManager.cs:4020)
0x000001e75bde7000 (Mono JIT Code) Gaia.GaiaSessionManager:EditorUpdate () (at C:/Users/peter/Documents/Unity Projects/Test/Assets/Procedural Worlds/Gaia/Scripts/SessionSystem/GaiaSessionManager.cs:899)
0x000001e6a51a5780 (Mono JIT Code) UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()
0x000001e57aee913d (Mono JIT Code) (wrapper runtime-invoke) object:runtime_invoke_void (object,intptr,intptr,intptr)
0x00007fff4a150394 (mono-2.0-bdwgc) mono_jit_runtime_invoke (at C:/build/output/Unity-Technologies/mono/mono/mini/mini-runtime.c:3445)
0x00007fff4a08eb44 (mono-2.0-bdwgc) do_runtime_invoke (at C:/build/output/Unity-Technologies/mono/mono/metadata/object.c:3066)
0x00007fff4a08ecdc (mono-2.0-bdwgc) mono_runtime_invoke (at C:/build/output/Unity-Technologies/mono/mono/metadata/object.c:3113)
0x00007ff61e73ce64 (Unity) scripting_method_invoke
0x00007ff61e71bc24 (Unity) ScriptingInvocation::Invoke
0x00007ff61e716885 (Unity) ScriptingInvocation::Invoke<void>
0x00007ff61e85e18b (Unity) Scripting::UnityEditor::EditorApplicationProxy::Internal_CallUpdateFunctions
0x00007ff61f248205 (Unity) SceneTracker::Update
0x00007ff61f36da39 (Unity) Application::TickTimer
0x00007ff61f7f60ea (Unity) MainMessageLoop
0x00007ff61f7fb060 (Unity) WinMain
0x00007ff620bc191e (Unity) __scrt_common_main_seh
0x00007ff8178b74b4 (KERNEL32) BaseThreadInitThunk
0x00007ff817e226a1 (ntdll) RtlUserThreadStart
Gaia Version: 3.3.1 PRO

Unity Info:
Unity Version: 2022.2.0b16
Company Name: DefaultCompany
Product Name: Test
Project Version: 0.1.0
Project Data Path: C:/Users/peter/Documents/Unity Projects/Test/Assets
Render Pipeline: URP

System Info:
Operating System: Windows 10  (10.0.19045) 64bit
Supports Compute Shaders: Yes
Supports GPU Instancing: Yes
Supports Ray Tracing: No
Supports Async Compute: No
Supports GPU Async Compute: Yes
Supports Texture Streaming: Yes

Graphics Info:
Graphics Card Vendor: NVIDIA
Graphics Card Name: NVIDIA GeForce RTX 3090
Graphics Card Version: Direct3D 11.0 [level 11.1]
Graphics Driver Version: Direct3D11
Graphics Card Memory: 24348 MB

Processor Info:
Processor Name: Intel(R) Core(TM) i9-10900K CPU @ 3.70GHz
Processor Core Count: 20
Processor Speed: 3696 GHz

Memory Info:
Memory (RAM): 65407 MB


Tried creating new projects, different World settings but result is the same.

Link to comment
Share on other sites

23 minutes ago, KeycapGames said:

Same issue, did you find a solution?

Nope, I'm just working on the stuff that doesn't require Gaia for now. I hope some dev can help.

Link to comment
Share on other sites

  • Solution

@KeycapGames @7Dev.io The crashes you reported were related to the new Unity 2022.2 version which just came out of beta yesterday. We usually do not support beta versions but rather make our products compatible after the Unity version comes out of beta. We just released the Gaia update that brings compatibility with 2022.2 on Canopy and the asset store, this should fix this issue.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...