Jump to content

Receiving errors in new Project with Gaia Pro 2021 right off the Asset Store


BIG
 Share

Go to solution Solved by Peter,

Recommended Posts

We're starting a new project with Gaia Pro 2021 and we're getting errors about Unity Standard Assets components that appear to be missing. When we went to include standard assets, there are two issues:

1/ The standard assets are deprecated by Unity and there is an expectation that they will be removed. They have split the standard assets into two different packages and it is not clear what we should be doing about this.

Specific error: Assets\Procedural Worlds\Gaia\Asset Samples\Standard Assets\Characters\FirstPersonCharacter\Scripts\FirstPersonController.cs(165,40): error CS1061: 'CharacterController' does not contain a definition for 'isGrounded' and no accessible extension method 'isGrounded' accepting a first argument of type 'CharacterController' could be found (are you missing a using directive or an assembly reference?)

To resolve we have tried importing"Standard Assets for Unity 2018.4.

2/ Including the legacy standard assets did not resolve our issue. Some of the UnityStandardAssets errors went away, but others remain resulting in a project that cannot build due to some features with UnityStandardAssets. 

Assets\Standard Assets\Cameras\Scripts\FreeLookCam.cs(3,27): error CS0234: The type or namespace name 'CrossPlatformInput' does not exist in the namespace 'UnityStandardAssets' (are you missing an assembly reference?)

Assets\Standard Assets\ParticleSystems\Scripts\Explosive.cs(4,27): error CS0234: The type or namespace name 'Utility' does not exist in the namespace 'UnityStandardAssets' (are you missing an assembly reference?)

Assets\Standard Assets\ParticleSystems\Scripts\Explosive.cs(17,17): error CS0246: The type or namespace name 'ObjectResetter' could not be found (are you missing a using directive or an assembly reference?)

It appears that perhaps you're using this for creating controllers to preview scenes and such and we will NEVER need this functionality as we have our own systems for such things and would like to remove the need for any external components that we aren't going to be using to reduce our build side and the codebase size we have to maintain.

{

Please note: This is a Legacy package that is no longer maintained and supported

 

For character controllers compatible with 2020 LTS, please check out Starter Assets: First Person and Third Person.}

Link to comment
Share on other sites

  • Solution

Hi there, normally you should not run into this issue when you install Gaia into a new project (as long as it is a supported version,) While it is correct that Gaia uses code from the old unity standard assets package, the code has been modified / selected to run as standalone with the Gaia installation. It should NOT be required to install the old unity standard assets package.
I looked a bit in the error you were experiencing. The error message says that the "CharacterController" class would not have a field named "isGrounded". This is not correct however, the class in question should be out of the unity engine namespace, which has a "isGrounded" definition in all relevant versions of Unity:
https://docs.unity3d.com/2020.3/Documentation/ScriptReference/CharacterController.html
This usually means there is something in the project that overrides the linking of the class "CharacterController" in the standard namespace. This could be an user script or another asset - both not likely since you said it is a new project. Could you please do the following to check the issue:

1. Double click on the 1st error message mentioning "isGrounded". It should open the offending line in your code editor. 
2. Hover with the mouse over the term "m_CharacterController". It should show you the type of this term / where the expression "m_CharacterController" is pointing to:
image.png

3. Click on that term, or right click on m_CharacterController and select Go to definition. Where does this take you? Correct would be that it displays you the class definition from unity from the metadata:

image.png

Here you should also be able to see that it has a field called "isGrounded". If this takes you somewhere else, or the "isGrounded" is not there, this would be the issue then, depending on what that is I can advise further.

Link to comment
Share on other sites

Thank you for the assist.

 

The problem was with another class called CharacterController that was not in the UnityEngine namespace but in the default namespace. This was causing a collision which resulted in the issue that we're seeing as UnityEngine is higher in the imports than our stuff.

 

This can be marked as closed.

Link to comment
Share on other sites

  • Ben Black locked and unlocked this topic
  • Ben Black locked this topic
Guest
This topic is now closed to further replies.
 Share

  • Tell a friend

    Love Unity 3D World & Game Creation Tools - Canopy - Procedural Worlds? Tell a friend!
  • Interesting Articles

    1. 0

      Different layers are being combined together.

    2. 42

      GeNa Pro City Generator

    3. 1

      World Creator + Gaia

    4. 1

      Gena decorator??

    5. 1

      Objects spawning at unexpected position in segmented scene.

×
×
  • Create New...