Jump to content

Masks clipping at short distance.


Liam Visionary
 Share

Go to solution Solved by Liam Visionary,

Recommended Posts

For some reason, masks I've applied are showing fine from a distance, but start to fade out the nearer I get. Looking at the terrain layers, they are indeed there. They're just not rendering nearby. Here is a video showcasing the issue: 

https://discord.com/channels/423247963457060866/832495840077283368/925774826826784779

 

Also I can't get slopes to spawn with my slope masks. This could seemingly be linked to the above issue, but since I can't get close enough to verify, I'm not sure.  Would these be the correct settings to spawn cliff textures at slopes between 35 and 90 degrees? 

https://discord.com/channels/423247963457060866/832495840077283368/925629821919322142

Couldn't post the photo here since it exceeds Canopy's 500kB limit.

EDIT: Also regarding that limit, I think it should be increased. I took two more screenshots, this time cropping them to cut down on the size, and they still exceed the 500kB limit. I'm alright with the switch over to Canopy, but one of the great things about the discord server was the back-and-forth dialogue and the simplicity of uploading videos and images. 

EDIT2: Here are the photos posted to discord:

https://discord.com/channels/423247963457060866/832495840077283368/926162957824565270

Edited by Liam Visionary
Tried to upload new images
Link to comment
Share on other sites

27 minutes ago, Liam Visionary said:

For some reason, masks I've applied are showing fine from a distance, but start to fade out the nearer I get. Looking at the terrain layers, they are indeed there. They're just not rendering nearby.

The masks itself would only render if the visualization is enabled. It looks like your video is just showing the final textures / terrain layers on the terrain. The difference in looks when zooming in / out looks like it could be the differences in shadow cascades and / or the base map of the terrain. 
 

42 minutes ago, Liam Visionary said:

Would these be the correct settings to spawn cliff textures at slopes between 35 and 90 degrees?

The settings look correct to me, note though that 35 degrees is quite steep already, I would not expect much areas in your terrain to have that steepness. The strength transform curve looks like it is not linear either which might further amplify the problem. Could you please try if it works if you start with 0 degrees as a minimum, then restrict it further and further?

Agree on the file upload limitations, we need to make this a bit less strict for easier posting of images and video for these cases.

Link to comment
Share on other sites

On 12/30/2021 at 1:04 PM, Peter said:

The masks itself would only render if the visualization is enabled. It looks like your video is just showing the final textures / terrain layers on the terrain. The difference in looks when zooming in / out looks like it could be the differences in shadow cascades and / or the base map of the terrain. 
 

The settings look correct to me, note though that 35 degrees is quite steep already, I would not expect much areas in your terrain to have that steepness. The strength transform curve looks like it is not linear either which might further amplify the problem. Could you please try if it works if you start with 0 degrees as a minimum, then restrict it further and further?

Agree on the file upload limitations, we need to make this a bit less strict for easier posting of images and video for these cases.

 

Hey Peter, thanks for getting back to me and sorry for the late response, things got hectic. So I enabled visualization, respawned locally, and while I can see the changes from a distance such as is seen in the video above, I cannot see those changes nearby. It is the same in play mode. From a distance, I see dirt texture patches everywhere, yet when I approach closer -- its just the grass texture. I end up with a very strong borderline between terrains 😕 Here are some photos of what I'm seeing in playmode:

 

Linking discord again because my images  (1.7mb) exceed even in the increase 1000kB limit images: https://discord.com/channels/423247963457060866/832495840077283368/926602075461267517

 

Also, I changed the slope curve to start with 0 and go up to 60 degrees, but I'm not seeing my cliff texture. Also the documentation mentioned that a slope of 0 is flat ground and 90 is a vertical wall. Is that not actually the case? 

Quote
Min Max Slope Here you can enter the minimum and maximum slope angle in degrees for your slope mask, either via a range slider or by entering numerical values directly.  The slope angle is measured vs. a completely even terrain without any incline. The values written below the slider serve as indication, starting from 0 degrees (no incline) to 45 degrees in the middle to 90 degrees (a vertical wall in right angle to the ground)

Introduction to Masks : Procedural Worlds (freshdesk.com)

 

 

Edited by Liam Visionary
Link to comment
Share on other sites

  • Solution

Issues resolved by deleting session data and starting a new terrain (thankfully, I wasn't too far along). Everything is now working as expected.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...