Jump to content

Gaia Underwater. No background - no Skybox - Just black.


Recommended Posts

Im wondering if someone could help me out with something.  I have the light Gaia 2021, everything is working pretty A.O.K, except one thing.  I can not figure out how to see, or rather, why I can not see, anything once i am under the water surface except the terrain, and water caustics on the terrain surface below the water surface.  Theres no color, theres no fog.  


Gaia 2021, Unity 2021.3.5f, and HDRP


I am NOT using the Gaia player.  I have a custom controller / camera setup, though i have provided a local volume witht he supplied underwater profile, but that seems to change nothing. I just simply can not see any background but black.


A: underwater background.

B; Above water. 

C- In Car View

Even without build / play mode running, as soon as scene camera goes under the water surface, its black.  I mean, i wouldnt even mind if there was some bluish color or something, but nothing I have attempted has worked.





It really doesn't seem so much like as underwater, as more like in outer space. 😄


Though as i mentioned, i am not using the Gaia hdrp setup, only the provided underwater profile. Im sure something in configuration is probably the issue, but i do not know enough about hdrp and profiles to resolve it, assuming that is the issue,


Link to comment
Share on other sites

SOLVED: Didnt even need a script. All working well. Thanks anyways.

Sorry for a double post, but i believe i have my solution.


So Oh Hey neat, as i have been really really struggling and at the time i posted this, still struggling to work my way through this, still toying - i did happen to notice that a override profile is being added at runtime to my scene from Gaia... but ... ofc it is in a state of disabled, so when i enabled it, whoila, it starts looking like it should.  I am not using the gaia player at all, but i assume this is related to the unaffected reaction of the profile.


That said, However, i think between my recent observations, a trigger, and a little script, i may have found a resolve. Thanks anyways. Good day.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...