Jump to content

Gaia underwater effects messed up


mroshaw
 Share

Recommended Posts

Me again!

 

Something has gone wrong with my Gaia water setup, and I'm getting really weird artefacts and corruption when I go underwater:

 

image.png.c85dc8685439ab0f4ce6bc6e71e57847.png

I've tried removing the water system via Gai Runtime, and adding it in again. No impact by temporarily disabling any of the Post Processing Volume, Underwater FX, anything like that. Even with all child objects inactive, the water is rendering as above. Lots of black areas, squared off, lots of weird aliasing around the character and that weird reflection that you can see to the left of the character.

 

I've uploaded a video, to show the behaviour more clearly: 

 

 

I've also tried disabling the Planar Reflection Probe, thinking this might have something to do with it, but to no avail.

 

Any thoughts?

 

Oli

Link to comment
Share on other sites

Can you please tell me if you are using the Gaia Custom Player for your character and camera? 
Does the Camera have post effects turned on in the inspector? 
 

Link to comment
Share on other sites

Hey Bryan,

 

Yes, using Gaia Custom Player:

image.png.41fafc408a58bed8aa49f8d971d5f21a.png

 

On my "Gaia Main Camera" camera, I've disabled "Customer Frame Settings". In my Project Settings > HDRP Global Settings, I have the following:

 

image.png.c4caf9b830dab12452c56636fc28c794.png

 

Is this the setting you're referring to?

Link to comment
Share on other sites

I think I've narrowed this down to Depth of Field. If I uncheck the "Depth of Field" override on the "Underwater Post Processing" volume, the corruption mostly goes away. There's still some weird artefacts around the player model, if viewed by a camera above the water:

image.png.4702b437b7031f6af8ebb951a96d6a1b.png

 

I don't understand why Depth of Field is causing this, though! Everything seems to be setup correctly in my HDRP Settings and on the Camera.

 

Very odd!

Link to comment
Share on other sites

So this could be a few things. 
The most common is the render order / layer sometimes adjusting this would fix the issue. 
Otherwise reflections would be needed, I will have to look this up as this would happen with or without Gaia. 
Pretty much and water can cause this issue. 

I will look and see what I can find, but try the render order / layers. 
 

Link to comment
Share on other sites

Thanks again, Bryan.

 

By "render order", do you mean the priority on the Volume?

 

I do have two layers that I use for HDRP Volumes, so I can definitely try consolidating that down or switching it around.

 

I'll let you know what I find.

Link to comment
Share on other sites

Just out of interest, does HDRP Time of Day apply any of it's own Post Processing or Volume Overrides for underwater effects?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...