Jump to content

Does not work in build but works in editor.


Meudes
 Share

Go to solution Solved by Meudes,

Recommended Posts

Hello,

Gaia version 3.3.0

Unity 2021.3.8f1

 

I create a new scene I create a new worlds

- 2 Tiles x 2 Tiles
- Tiles Size 512 m Sq
- Tiles Height 512
- Create Terrain Scenes : check
- Unload Terrain Scenes : check
- Desktop
- Alpine Meadow
- World Designer

 

I change the name of the session

I Generate World

I add the RunTime

I add the scenes in the Build Settings

I Build and Run: it works

 

I respawn terrain textures

I build and run: I have a black windows

In the editor: it works.

 

Is there a place where I can find logs or other. I've been completely stuck...for a long time.

Thanks in advance

Link to comment
Share on other sites

Hello, we do not have control over the build. 
From the sounds of it the build was bad though. 
I would try rebuilding and seeing if that works, otherwise the best bet is to contact Unity. 
If the first build was correct, then the second one should be fine. 
If you are using world streaming make sure to unload the scenes before building. 
To do this go to the Gaia Runtime and then Terrain Loading Manager - Unload Terrain scenes. 
Then build your game. 

Hopefully this helps you! 

Let me know how it goes.

Link to comment
Share on other sites

Hi @Meudes have you tried running a development build yet? If you are lucky, you will see error messages in a console window in the build. 

image.png

Next thing to check would be the player logfile, if you look at the very end you might see an error there or some log entries that give you an idea what is going on. You can right-click on the console tab and select "Open Player Log" in the newer unity versions, alternatively you can find the directories for the player log here:
https://docs.unity3d.com/Manual/LogFiles.html
(Make sure to check the Player logfile as that is the one relevant for the build!)

If that does not help, you could try the following method: Disable all Game Objects in the scene besides the camera, build the scene, see if it shows the empty unity scene now. Then you can activate more and more game objects and build again to see at which point it starts showing the black scene, this would at least give an indication from which area the black screen comes from.

Link to comment
Share on other sites

  • Solution

I had already looked at the logs...
After a lot of testing, it seems that disabling gaia tools works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...