Jump to content

[PLEASE MOVE TO GTS FORUM] Black squares on textures when using GTS - Can fix issue but comes back on save


h2hjastermereel
 Share

Go to solution Solved by h2hjastermereel,

Recommended Posts

  • Solution

Note: I have verified that I have ONLY 8 textures per terrain.

 

I am using the built in GTS profile and not changing anything. After applying the profile I noticed these little black squares on ground textures (in 3 of my 4 terrain scenes). I dug into my terrains to see what was different and noticed that in the terrains with the black squares it seems the GTS profile was not applied (the shader material preview is black (the control0 and control1 textures are pure black!) - using GTS built in HDRP shader). After applying to each terrain it was fixed and the control0 and control1 textures were created properly. BUT - as soon as I save they revert back to black textures and therefore show the black squares. Lot's of pics attached.

2 - after_applying_GTS_profile.png

1 - before_applying_GTS_profile.png

3 - after_saving.png

 

 

Not sure if this is related or not, but I do see this error in the console:

"Asset import failed, "Assets/Procedural Worlds/GTS/Shaders/HDRP/GTS_HDRP.shadergraph" > NullReferenceException: Object reference not set to an instance of an object
UnityEditor.Rendering.HighDefinition.ShaderGraph.HDSubTarget.GetMetadataObject (UnityEditor.ShaderGraph.GraphDataReadOnly graph) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.7/Editor/Material/ShaderGraph/HDSubTarget.cs:75)
UnityEditor.Rendering.HighDefinition.ShaderGraph.HDTarget.GetMetadataObject (UnityEditor.ShaderGraph.GraphDataReadOnly graph) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.7/Editor/Material/ShaderGraph/HDTarget.cs:249)
UnityEditor.ShaderGraph.ShaderGraphImporter.OnImportAsset (UnityEditor.AssetImporters.AssetImportContext ctx) (at Library/PackageCache/com.unity.shadergraph@12.1.7/Editor/Importers/ShaderGraphImporter.cs:209)
UnityEditor.AssetImporters.ScriptedImporter.GenerateAssetData (UnityEditor.AssetImporters.AssetImportContext ctx) (at <0d6ce211ebbc47e1a35a84c3672ff58f>:0)"

 

SOLUTION: Found here: 

 

 

Basically I had to delete the folders and recreate the GTS materials. It would work for one, then another until I finally had them all fixed and saved.

 

Link to comment
Share on other sites

  • h2hjastermereel changed the title to [PLEASE MOVE TO GTS FORUM] Black squares on textures when using GTS - Can fix issue but comes back on save

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

×
×
  • Create New...