Jump to content

An installation issue.

Go to solution Solved by GeekGangGames,

Recommended Posts

When I install the latest Gaia Pro in Unity 2021.3.7fi, I get the following errors:

An error occurred while resolving packages:
  Project has invalid dependencies:
    com.unity.render-pipelines.high-definition: Package [com.unity.render-pipelines.high-definition@12.1.0] cannot be found
    com.unity.render-pipelines.universal: Package [com.unity.render-pipelines.universal@12.1.0] cannot be found
    com.unity.shadergraph: Package [com.unity.shadergraph@12.1.0] cannot be found

A re-import of the project may be required to fix the issue or a manual modification of D:/The Old Bones/Packages/manifest.json file.

Unable to update following assemblies:Assets/Procedural Worlds/Flora/Scripts/Core/ProceduralWorlds.Flora.Core.dll (Name = ProceduralWorlds.Flora.Core, Error = 131) (Output: C:\Users\admin\AppData\Local\Temp\tmp18cc58bf.tmp)


I can read what it's saying, that it's not finding pipelines, but I'm working with the Built-In Pipeline, and I haven't asked it to compile in URP or HDRP. I'll keep fiddling with it until I figure it out, and post if I figure it out by myself.

Link to comment
Share on other sites

  • Solution

So, apparently Unity does not install with up to date URP or HDRP pipelines all of the time. I updated those via package manager, and the error went away.


A good solution to that issue from this side might be not making Gaia dependent on pipelines it is not using.

Link to comment
Share on other sites

2 hours ago, GeekGangGames said:

A good solution to that issue from this side might be not making Gaia dependent on pipelines it is not using.

This is the case already, otherwise Gaia would break instantly if you e.g. would run it in a project where no other pipeline is installed. You need to go through a dedicated setup process to unlock the pipeline specific code in Gaia.
I would expect that error to occur on potentially any .dll that you import into your project if there is an issue with package dependencies.

  • Like 1
Link to comment
Share on other sites



Well, I installed Gaia on a project running the built-in pipeline, but it wouldn't compile because it said it had package dependencies on URP and HDRP. It compiled once I updated the HDRP and URP packages in Unity. It was just the first time I ran into an unused-in-project package dependency like that, so it was confusing.

Plus, heh, I can't pretend I know this engine inside and out, so you know, grain of salt and all that ... lots of stuff to figure out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...