Jump to content

Scene view displaying nothing after activating Day/Night Preview


Xynon
 Share

Recommended Posts

After turning on the Day/Night preview in a freshly imported and setup scene, the entire scene view shows only featureless grey. Reverts back to non-preview runtime just fine, and game view works fine, but the scene view is unusable.

2 Errors are spammed in the log when this occurs:

Render Graph Execution error at pass Volumetric Clouds Ambient Probe (4) UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

NullReferenceException: Object reference not set to an instance of an object UnityEngine.Rendering.HighDefinition.PhysicallyBasedSkyRenderer.RenderSky (UnityEngine.Rendering.HighDefinition.BuiltinSkyParameters builtinParams, System.Boolean renderForCubemap, System.Boolean renderSunDisk) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.2/Runtime/Sky/PhysicallyBasedSky/PhysicallyBasedSkyRenderer.cs:472) UnityEngine.Rendering.HighDefinition.SkyManager.RenderSkyOnlyToCubemap (UnityEngine.Rendering.CommandBuffer commandBuffer, UnityEngine.Rendering.RTHandle outputCubemap, System.Boolean includeSunInBaking, UnityEngine.Rendering.HighDefinition.SkyRenderer skyRenderer) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.2/Runtime/Sky/SkyManager.cs:574) UnityEngine.Rendering.HighDefinition.HDRenderPipeline+<>c.<PreRenderVolumetricClouds_AmbientProbe>b__365_0 (UnityEngine.Rendering.HighDefinition.HDRenderPipeline+VolumetricCloudsAmbientProbeData data, UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraphContext ctx) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.2/Runtime/Lighting/VolumetricLighting/HDRenderPipeline.VolumetricCloudsLighting.cs:153) UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraphPass`1[PassData].Execute (UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraphContext renderGraphContext) (at Library/PackageCache/com.unity.render-pipelines.core@12.1.2/Runtime/RenderGraph/RenderGraphPass.cs:151) UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraph.ExecuteCompiledPass (UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraph+CompiledPassInfo& passInfo, System.Int32 passIndex) (at Library/PackageCache/com.unity.render-pipelines.core@12.1.2/Runtime/RenderGraph/RenderGraph.cs:1324) UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&)


 

Link to comment
Share on other sites

10 minutes ago, Xynon said:

After turning on the Day/Night preview in a freshly imported and setup scene, the entire scene view shows only featureless grey. Reverts back to non-preview runtime just fine, and game view works fine, but the scene view is unusable.

2 Errors are spammed in the log when this occurs:

Render Graph Execution error at pass Volumetric Clouds Ambient Probe (4) UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

NullReferenceException: Object reference not set to an instance of an object UnityEngine.Rendering.HighDefinition.PhysicallyBasedSkyRenderer.RenderSky (UnityEngine.Rendering.HighDefinition.BuiltinSkyParameters builtinParams, System.Boolean renderForCubemap, System.Boolean renderSunDisk) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.2/Runtime/Sky/PhysicallyBasedSky/PhysicallyBasedSkyRenderer.cs:472) UnityEngine.Rendering.HighDefinition.SkyManager.RenderSkyOnlyToCubemap (UnityEngine.Rendering.CommandBuffer commandBuffer, UnityEngine.Rendering.RTHandle outputCubemap, System.Boolean includeSunInBaking, UnityEngine.Rendering.HighDefinition.SkyRenderer skyRenderer) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.2/Runtime/Sky/SkyManager.cs:574) UnityEngine.Rendering.HighDefinition.HDRenderPipeline+<>c.<PreRenderVolumetricClouds_AmbientProbe>b__365_0 (UnityEngine.Rendering.HighDefinition.HDRenderPipeline+VolumetricCloudsAmbientProbeData data, UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraphContext ctx) (at Library/PackageCache/com.unity.render-pipelines.high-definition@12.1.2/Runtime/Lighting/VolumetricLighting/HDRenderPipeline.VolumetricCloudsLighting.cs:153) UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraphPass`1[PassData].Execute (UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraphContext renderGraphContext) (at Library/PackageCache/com.unity.render-pipelines.core@12.1.2/Runtime/RenderGraph/RenderGraphPass.cs:151) UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraph.ExecuteCompiledPass (UnityEngine.Experimental.Rendering.RenderGraphModule.RenderGraph+CompiledPassInfo& passInfo, System.Int32 passIndex) (at Library/PackageCache/com.unity.render-pipelines.core@12.1.2/Runtime/RenderGraph/RenderGraph.cs:1324) UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&)


 

It's a unity HDRP bug normally pressing play and exiting play mode or reloading the project fixes it. 

Link to comment
Share on other sites

3 minutes ago, Xynon said:

Attempted both of those and still getting the same error

Ah, well then this would be a unity bug with that version of HDRP. You can always try creating a new HDRP Render Pipeline asset and assigning the newly created one. If this does not work you can try re-installing HDRP other than that you may have to contact Unity about htis bug so they can fix it in the next HDRP version.

What did you mean by Day/Night Preview?

Link to comment
Share on other sites

Still havent found anything on this online 😕 anyone else had this issue? I am going to need to start using scene view heavily for the main scene soon, hoping to work this out before then.

Link to comment
Share on other sites

2021.2.71f, HDRP version is 12.1.0 i believe? something close to that, didnt realize it would disappear after i hit the upgrade button on the manager!

Also, just finished reimporting, setting up manager now.

Edited by Xynon
Link to comment
Share on other sites

Could you make a video of all the settings in the HDRP asset you are using? Want to see if you don't maybe have something checked that should be in our Gaia asset it should all setup but just to make sure.

Link to comment
Share on other sites

 

8 minutes ago, Josh said:

Could you make a video of all the settings in the HDRP asset you are using? Want to see if you don't maybe have something checked that should be in our Gaia asset it should all setup but just to make sure.

Cannot upload due to file size, if there are specific sections you want I could grab pictures.

Link to comment
Share on other sites

3 minutes ago, Xynon said:

Gotcha, i havent touched it since I am still new to HDRP so I was going to leave it however Gaia sets it, let me find it

It's under Edit/Project Settings/Graphics and the SRP asset image.png.1cee946e2dabdbc3c40faed981422371.png

I have looked and have noticed quite a few people having issues with HDRP 12.1.2 in that unity version with the physically based sky. The current preview version of the system was built in HDRP 12.1.0

Link to comment
Share on other sites

Its still labelled as the HDRenderPipelineAsset PWS HD 12.1.0, is there a different one it should be showing? I was using the Project Settings window to look at it.

Link to comment
Share on other sites

1 minute ago, Xynon said:

Its still labelled as the HDRenderPipelineAsset PWS HD 12.1.0, is there a different one it should be showing? I was using the Project Settings window to look at it.

No that is the right one and should have all the settings, well sadly the issue is Unity related and there is not much we can do about this until unity fix it in the next engine or HDRP version.

We will investigate it further to see if we can reproduce the issue and find a solution for you and any other user that may experience this same issue. Again it's a preview system and still in development, for the time being i'd recommend just using our base lighting setup profiles for now till the issue is resolved.

Are you able to use one of our other profile in Gaia Runtime/Gaia Lighting?

Link to comment
Share on other sites

I am able to use everything else, thank you for your assistance! I will just use one of the standard ones for now, and keep an eye out if yall mention anything about it 🙂 I understand these issues happen, especially using a brand new feature! Let me know if there is any other info I could provide that might help, and if something is figured out, please let me know!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Tell a friend

    Love Unity 3D World & Game Creation Tools - Canopy - Procedural Worlds? Tell a friend!
  • Interesting Articles

    1. 2

      I'm getting tired of doing islands and craters

    2. 2

      I'm getting tired of doing islands and craters

    3. 1

      Problems with latest Gaia Update

    4. 1

      Adding shoreline or waterline effects, beaches, river banks, etc.

    5. 1

      Just upgraded my Canopy to Pro

×
×
  • Create New...