Jump to content

Flora does not show on runtime

Go to solution Solved by Bryan,

Recommended Posts

Hi admins,

I want to fill my terrain with "PW_Grass_Terrain_01_D" as terrain details, and I want it to interact with the gaia wind system. However, when I uncheck "Enable Flora System", I am able to see the terrain details on runtime, but it stays still. When I check "Enable Flora System", I am unable to see the terrain details on runtime.

I have attached my terrain details settings and build settings below.

Pls let me know which part I should change, thanks in advance!


Link to comment
Share on other sites

Can you please click enable all and refresh terrain prototype? 
Then please check the terrain to make sure you have flora system in the terrain inspector. 

Also can you please tell me what character controller you are using? 


Link to comment
Share on other sites

Hi Bryan, thanks for getting back to me:)

I clicked enable all and refresh terrain prototype, and now during runtime I can see the terrain details with the flora system, but they don't sway in the wind. I think I see the flora system in the terrain inspector - "Flora Global Manager" as per the screenshot. The Flora Global Manager has a Flora Global Manager script attached to it. I'm using custom character controller - player and camera follow as the only camera - with some scripts detaching the camera follow from player and others re-attaching it.


Link to comment
Share on other sites

Oh ya I'm currently using URP, so when I tried to use Window > Procedural Worlds > Flora > Flora..., and click Add Flora To Scene, my terrain details disappear on runtime, since it says "Flora currently works in HDRP only." What would be the URP solution to enable terrain details to sway in the wind haha

Link to comment
Share on other sites

I think I know the issue here. 
The reason its not flowing in the wind is due to the player. 
If you are using a custom player you will need to use Gaia Custom Player. 
Then please assign the camera and player to that. 

Then I believe the wind should start working. 

Link to comment
Share on other sites

Hi Bryan,

Oh I see. My Gaia runtime is set to "Create Runtime" > Player Controller: Custom > with player and camera dragged into the fields. Is this Gaia Custom Player? Hm I do currently see the scripts Terrain Loader, Rigidbody Wait For Terrain To Load, Floating Point Fix attached to my player and Location System attached to my camera. I tried to manually attach Custom Gaia Controller (Script) to my player and check isPlayer, or not attach it, but either way the wind system is not activated.

Thanks in advance:)

Link to comment
Share on other sites

Ok can you please try the following. 

Enable Flora, then please check the Flora Source Camera in the terrain inspector. 
Make sure that you are using the custom player and your camera is set to main camera. 

Link to comment
Share on other sites

Hi Bryan, thanks for getting back to me!

Hm I couldn't find Flora Source Camera. Do you mind providing how I could navigate to it? Thanks in advance:)

Or actually, I've detailed below the goal I want to achieve. Would appreciate it if you don't mind providing a step by step guidance on how I could achieve it (if custom player really can't work out, for some reason, I guess I can use FlyCam and assign it to my scripts that use it, but I tried to recreate my scene approximately with my FlyCam once and it didn't work out either).

I recreated my building process in a new scene.


(1) Project's in URP. Here're my settings


(2) So I did a Window > Procedural Worlds > Gaia > Show Gaia Manager and loaded in the gaia manager.

(3) I create world with these settings: 179891576-2eca3e42-c102-4087-8cda-d8c9a5

(4) I go to Gaia Tools > Stamper > Operation Settings, and set it as such. I then click "Stamp".


Here's CampusHeightMap.jpg


I then use "Add Height" to add a 4k plains 3. And I click Stamp.


(5) For this test scene, I used a Unity capsule as my player, and I attached my main camera to it. Main camera still has the tag MainCamera. Player is tagged "Player".

(6) I create runtime as such. I use a custom skybox so I chose None for Skies.


(7) I then returned to Gaia Tools > Custom Biome and did the following for terrain texture:



I click on Spawn World to spawn them.

(8) I then create another spawner (for my terrain details)

Here are my settings for my grass


I then click PW Grass System > Enable All, Yes create settings.

I notice that I got this error message, which may or may not generated be at this stage as I previously didn't check my console, not sure if it is relevant:

```EngLayoutGroup: BeginLayoutGroup must be called first.
UnityEngine.GUILayout:EndVertical ()
Gaia.SpawnerEditor:DrawSpawnRulesPanel (string,System.Action`1<bool>,bool&,bool) (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:4258)
Gaia.SpawnerEditor:OnInspectorGUI () (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:1559)```

I got it 4 times, and they are the same message just with different lines referenced.

Anyway, I click refresh terrain prototype, add terrain prototype.

I then spawn flowers with these settings:


and enabled flora via the exact same procedure. I didn't get any error message when doing so.

I then click spawn world to spawn my terrain details.

I got this appearance:


The grass does sway in the wind but it does not look like how it should 


I then realised that I forgot to set the terrain detail density to my liking so I went back and set it as such:


I then click "Apply to all terrains". I then realised that it didn't apply to terrains that are not active, so I increased loading range to 973 then clicked "Apply to all terrains" again.



When I hit play this is what I saw:


I went to terrain details and saw that Terrain Detail Overwrite was set to 0 for both data. When I increased it I saw this:


There seem to be 2 systems loading at the same place. The off-coloured and off-shaped portion (as shown in my previous screenshot) swaying in the wind, and the correctly-coloured portion static.



I went back to my terrain details spawner and clicked "Auto create config" for my grass and my flower.

I got the error message:

EndLayoutGroup: BeginLayoutGroup must be called first.
UnityEngine.GUILayout:EndVertical ()
Gaia.SpawnerEditor:DrawSingleRulePanel (Gaia.SpawnRule,int) (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:4740)
Gaia.SpawnerEditor:DrawRegularSpawnRules (bool) (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:4454)
Gaia.SpawnerEditor:DrawSpawnRulesPanel (string,System.Action`1<bool>,bool&,bool) (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:4222)
Gaia.SpawnerEditor:OnInspectorGUI () (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:1559)
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&) (at /Users/bokken/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:189)

twice and

EndLayoutGroup: BeginLayoutGroup must be called first.
UnityEngine.GUILayout:EndVertical ()
Gaia.SpawnerEditor:DrawSpawnRulesPanel (string,System.Action`1<bool>,bool&,bool) (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:4255)
Gaia.SpawnerEditor:OnInspectorGUI () (at Assets/Procedural Worlds/Gaia/Scripts/Editor/SpawnerEditor.cs:1559)
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&) (at /Users/bokken/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:189)

twice, for each time I press the button (ie 8 error messages in total).

I ignored them, clicked refresh terrain prototype, then pressed Play again.

Now they look right, but nothing sways in the wind.



On a side note, when I tried to drag a unity 3d sphere (with a sphere collider of its radius) across the grass, I realised that it just cuts into the grass mesh rather than actually interacting with it. Is there a way I could make it interact slightly more realistically, or is that a limitation of terrain details?


Thanks for reading all these and I genuinely look forward to your reply.

Link to comment
Share on other sites

Are you wanting to use billboards on purpose? 
I am thinking that you might want to be using Grass as the render mode instead. 
This would be in the grass resource settings. 

The custom player really is only needed if you are using your own character and camera. 
Multiple cameras I suggest using custom as well. 

End Layout Group warning message is fine doesnt hurt the project and happens regardless if PW tools are in the project or not. 
Remember that billboard grass rotates with the camera and creates a weird and interesting effect. 
Which might be what you are experiencing. Unless you are needing the grass to rotate for you. 


Link to comment
Share on other sites

Yup! That is the effect I'm trying to create. I changed my render settings to Grass for both grass and flower, refreshed terrain prototype and clicked Autocrat config. But when I hit Play this was the terrain. I tried to use Spawn World to get rid of this weird colouring but it didn't work as well.



The appearance I want is what I saw in the editor:


Link to comment
Share on other sites

Can you please go to the Gaia Manager- Advanced - Tools- terrain helper, and remove the terrain details. 
Then please spawn the grass and flowers again. 

Link to comment
Share on other sites

Hi Bryan, I couldn't find terrain helper so I cleared all terrain details from all terrains from the Biome game object. The problem persists.

Link to comment
Share on other sites

You could try to turn these parameters up and down on the objects material to see if they would make a difference. 

Here is where the Resource Helper is: 

I would recommend using this to clear the details and then try spawning again. 

Link to comment
Share on other sites

Hi Bryan, I removed everything and spawned everything again but it's still not working. It still looks aweful and only a little patch was rendered on runtime. The objects don't display those fields you showed in the screenshot though, not sure where to find them.

The build issue as well (I posted as a separate thread but it was ignored). When I build Gaia to iOS, I just see a black screen with no content at all.

I would like to appeal for a refund as Gaia is not working out for me. I can video call and demonstrate how the functions are not working, to show that the lack of functionality is not made up. Pls let me know which channel I could send the request to.

I think Gaia is a powerful asset that has been well thought-out. But for now, I'd like to return it.

Link to comment
Share on other sites


I understand that it's past the 14 days refund limit on Unity's side and to request for a refund is not strictly by the policy. But this was the only scene I needed to build using Gaia and I think throughout this thread we've both tried various ways to fix it but I think we have both realised that it is not working out. I would genuinely appreciate if you could reflect this situation and let me know how I could return Gaia till next time.

Link to comment
Share on other sites

  • Bryan locked this topic
This topic is now closed to further replies.
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...