Jump to content

How to record a rendered video with Pegasus

Go to solution Solved by Bryan,

Recommended Posts

I wanted to record a fully rendered fly through with Pegasus. I created a timeline and put a record channel on it with a new recording. It outputs the gameview camera and saves the video. The problem is when I hit play the recording is moving slow, as expected since it’s rendering each frame. But the Pegasus flythough runs at normal speed. So the fly through is around 2minutes and when it finishes, only around 40 seconds have been recorded which makes the fly through much faster than it actually is.


How would I sync Pegasus to the timeline so I can output a fully rendered video?

Link to comment
Share on other sites

Ok, I added a Pegasus track to the timeline and put the manager on the Pegasus track. But when I hit play the camera doesn’t move. If I jump to a different part of the fly through using the inspector options on the Pegasus manager the camera does start to move, but the camera movements are way off. It seems the camera is traversing at the same rate as the video render but it’s POI’s are not. So if my POI’s are 30 seconds apart and it renders that segment in 60 seconds, in the render the POI change comes at 15 seconds, not 30.

Link to comment
Share on other sites

  • Solution

Did you change the Camera target in the Pegasus Capture? 
In the Pegasus Manager under Utilities, did you set the speed of the camera or are you adjusting each point? 

What are you using to record? 
In the past, I use the Unity Recorder and tie that to Pegasus and it does great. 


Link to comment
Share on other sites

Thank you for the quick response! Sorry for my slow one, I just wanted to be sure I found what I did wrong. 

I’m using the fly through camera from Gaia Pro 21, it was set to the camera target in the Pegasus capture. I did have varying speeds on the POI’s, but the gameplay window played everything just fine. I tried recording with the timeline first, then just the Unity Recorder like you had suggested and I still had the same problem. I even went to a project backup before I bought Pegasus and had the same issue. So I created a new project with just Gaia Pro 21 and Pegasus to eliminate if it was something I did or a problem with the software. The new project rendered completely fine with no issues. I went back to the original project I was trying to get this to work with, double checked everything, opened a new recorder and still had the problem. Then I remembered I had deleted the original fly cam I had in the scene to play with the Gaia runtime stuff. So I went to the Pegasus manager and even though the camera target said “fly cam” and game time showed the fly through fine, I dragged the fly cam that was currently in the scene into the camera target and it works perfectly now.

Thank you. I never would’ve thought to try to drag the fly cam into the camera target again without your reply. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...