Jump to content

problem creating the world

Go to solution Solved by Bryan,

Recommended Posts

Hi guys, all I can do is find this error in my scene over and over again, can someone tell me what it is due to? I can't find a solution online

this is a trace 🥴spacer.png


Assets/Gaia User Data/Sessions/GS-20221202 - 013220/Terrain Scenes/Terrain_3_2-20221202 - 202431.unity' couldn't be loaded because it has not been added to the build settings or the AssetBundle has not been loaded.
To add a scene to the build settings use the menu File->Build Settings...


I have my own controller in my scene, but even when I deactivate it, it still gives the same error

Link to comment
Share on other sites

I'm still investigating the bug, if I deactivate the gaia cloud component I no longer receive the warnings but I still have the same errors, now it just stays in infinite loadingspacer.png

Link to comment
Share on other sites

sigo investigando el bug, si desactivo el componente gaia cloud ya no recibo los avisos pero sigo teniendo los mismos errores, ahora solo se queda en carga infinitaI managed to solve the errors, I simply added the component that gaia requested (I still don't understand why) | now it just stays in infinite lospacer.png




I managed to solve the errors, I simply added the component that gaia requested (I still don't understand why) | now it just stays in infinite loading ! 

Link to comment
Share on other sites

Have you added all the scenes to the build window? 

If you are using Gaia Systems such as the terrain loading and streaming than yes you will need to use Gaia Custom Player and then assign your player and camera to that. 

If the player does not live in the scene you will then need to tie your player to it through the Gaia API. 
The GaiaAPI class is the official API, and in there each function is described in the source code.

  • Thanks 1
Link to comment
Share on other sites

Hi Bryan, ty for you help, check this 😄
I have my prefabricated character and the camera (in the scene), I just press play and nothing happens.spacer.png

Link to comment
Share on other sites

of course, use uvc controller, see this


In addition to this:
I tried to put the character of gaia in none and manually enter my controller, this does not give errors and everything seems to work fine, until I compile an apk,
I think I must be doing something really wrong
1* The weight of the apk is extremely large, now the apk weighs almost 300 mb, when that is the space I have to be able to make the complete game !!
2* when I try the apk now it doesn't go past the first screen, it just loads the made with unity screen and it doesn't show anything else (in editor it doesn't happen)
3* Is there somewhere where I can handle the performance of gaia?
4* my game is a mobile game (it hasn't started yet) I'm just doing tests with the frameworks that I'm going to use to see how optimal they are
5*I am seriously concerned about the weight (what systems are the ones that add so much weight?)

Link to comment
Share on other sites

Sadly those old integrations no longer work as the asset developers never updated their code for the integration. 
We do have documentation on how to get those integrations back if you do it yourself. 

Also looking at the car, it seems there are a lot of Gaia components missing. 
You should have the Terrain Loader (Script) 
Depending if you enabled Floating Point Fix (Script) that should be attached as well. 
RigidBody Wait For Terrain Load Script. 

The scene will be stuck in the loading if this is not attached to the player and you are streaming your world. 


Make sure that in your Gaia Runtime Parent you have the child 
Terrain Loader Manager as well. 


Link to comment
Share on other sites

Oh wow, didn't know that.
It would be helpful if you could tell me where to find the documentation.

Great, now I have the controllers apparently configured as you say, photo attached
Now I simply press play and it keeps loading in an infinite loop, but it seems to me that this happens with any other prefab, put a rock as controller and neither the instance :|.

Link to comment
Share on other sites

Actualizar !

desmarco la pantalla de opción de carga de ui y construyo apk, cuando se ejecuta apk en el dispositivo móvil solo se muestra la pantalla de unidad splas

It really is very basic what I want to achieve, but it seems that something is wrongly configured



Link to comment
Share on other sites

  • Solution


You need to adjust your Terrain Loader attached to the player - 

This cant be 0,0,0 
Adjust this to what you need. 

Secondly, when you are done working on your world make sure that you go into the Runtime Terrain Loader Manager. 
Then Unload all the terrains. 

Then you should be good to go. 


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...