Jump to content

GTS stripped terrain textures


Recommended Posts

I added GTS back to my project and it looked OK (other issue aside) until I saved. After I saved terrains became gunky brown when you move close to terrains. Switching off individual GTS features does not fix it. The problem remains as long as the profile stays active (in HDRP in 2021.3.8f1).

- Restarted Unity for good measure and the problem remained.
- Removing Profile and then Adding Profile again fixed the terrain
- As soon as I saved again it went gunky brown again.

It only happens when near to the terrain, which made me think it's related to 'detail' near and far options but the problem is there even with detail switched off






Link to comment
Share on other sites

Hi @newcolours,

For each terrain you have in your scene that has GTS applied to it:

  1. Select the terrain component, and navigate to its material slot:image.png.dd68c72d69ea08a67fed0fa15c681f0e.png
  2. Select the material in the project window:image.png.b056b718a7b481cac014e3d819424688.png
  3. Delete all contents in its folder:image.png.2168921034fa8bc2456341d1c0fbde2a.png

Apply the profile again:


Link to comment
Share on other sites

I tried this and don't get the expected results that you do

Before I apply GTS, the material is Digger/HDRP/Terrain/Lit and is in the DiggerData folder and the GTS User Data/Scenes folder contains only other empty folders.

Once I reapply GTS, the material selected from step 2 changes to a material in the Gaia User Data/Sessions folder and the GTS User Data/Scenes folder still contains only other empty folders.

Link to comment
Share on other sites

Hi @Illustrator, this warning can safely be ignored. This occurs because we convert a shadergraph terrain shader into a compiled HLSL one, which supports tangent space geometry - this feature is also benefical for shading the terrain on a mesh and not just Unity's terrain. 

Link to comment
Share on other sites

@newcolours can you confirm if any of the generated GTS materials, after saving, have a reference to a control map texture?

To do this, please check in the material's inspector if any of the control maps (_Control0 or _Control1) are populated? If you are only using 4 terrain layers then _Control0 should be the only map that has a reference. 

You can find the generated GTS material through looking at my first two steps I posted above. 



Also, can you tell me the location of where the generated terrain material is? Does it appear in a folder called GTS User Data, or does it appear in a folder where the scene was saved to?

Link to comment
Share on other sites

help me please, I see that there are many people with the same error, do you not have a stable solution to correct this error?

Link to comment
Share on other sites

@Illustrator Can you please check if you have a folder called Gaia1_ConiferousForest_4KHills4_LargeMap_GTSData, which may be in the same location as where the scene file is located?

If so, could you please delete it, remove the profile and apply it again? 

Link to comment
Share on other sites


There is no folder with the name Gaia1_ConiferousForest_4KHills4_LargeMap_GTSData that you have indicated (I am sending you an image of the location of the scene), what I have been able to find is the file "Terrain_0_0-20220813 - 153710(Terrain Data)" with the two Control_x textures , Should I delete this file? I have sent you images of everything I could, see if that way helps you solve the problem and thank you very much for your help and patience.







Link to comment
Share on other sites

Hi @Illustrator I spoke to Isaac briefly about this issue, and it would be great if you can provide us with a .zip file of the project if possible - this would allow us to look at the project ourselves to figure out what might be going on. I will write you a direct message with a link to a folder for file upload.

Link to comment
Share on other sites

No worries, this was just an additional offer to accelerate analysis. We will continue the search without looking into your project.

Link to comment
Share on other sites

@Illustrator, please delete the folder that you listed in your screenshot:


Then hit 'Apply Profile' again. 

Can you also check in the location where the scene file is saved, if a folder is also generated that shares the same name with '_GTSData' appended to it, such as this folder here:


If such a folder also exists, please delete it and hit 'Apply Profile' again.


Also, whilst it is probably unrelated to the issue, I see you are using Unity 2021.2.19f1. GTS supports a minimum version of 2021.3.0f1. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...