Jump to content

Can't get tessellation to work properly

Go to solution Solved by Isaac,

Recommended Posts


Wracking my brains on this one. HDRP 2021.3.5f1. 

No matter what I do, I cant seem to get the tessellation to displace the terrain where the mask height texture should be. When i change any of the values, the whole terrain shifts up, not just where the mask is. The intended effect should just be the swirls in the sand (as it is in the texture). 

Is there a different "height" slider to affect the displacement on the tessellation? 

Thanks in advance.



Link to comment
Share on other sites

Hi @badname, 

GTS uses the mask map texture's blue channel to determine the heightmap. Can you check if the SandPainted_Mask texture has height information stored in the blue channel? 

Link to comment
Share on other sites

Hi, can you also check the tessellation multiplier amount in the profile settings? If its 0 there won't be any tessellation on the terrain. This can also be debugged in the editor by viewing wireframe mode.


Could you also check whether the texture array conversion process was successfull - under the texture array settings, select the albedo array:


And check whether the alpha channel in the texture array has any height information stored in it:image.png.7cf65f142b5826e50ce03f31b8ca4bec.png


Link to comment
Share on other sites


Hey, I have attached the mask texture so you can take a look. Changing the tessellation I can see it affecting it in the wireframe. But still no displacement. Here is the full settings on the layer. Playing with all the values results in the same broken result.image.thumb.png.820ea3cbeabc13c7b108abaa5a07e87a.png


Alpha channel has the displacement

Appreciate your help so far


Link to comment
Share on other sites

  • Solution

Thanks for the mask map texture. Unfortunately, I haven't been able to reproduce the issue yet. When using that texture in a layer and re-generating the texture arrays, my sand layer behaves correctly. image.thumb.png.87755a89e36976cc0709fd0289ad5152.png

And adjusting it:image.thumb.png.b3c4e1b8097a89da4d04a89236230c2f.png


How many layers are on the terrain? And what are the import settings for the mask map texture?

Does the displacement work on a new scene with an empty terrain with just the sand layer? (You may want to duplicate the profile for this test)


Link to comment
Share on other sites

Ah hah! Regenerating the texture arrays worked! I must've had a bad heightmap before and didn't realize they wouldnt reupdate if I updated the texture. 


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tell a friend

    Love Canopy - Procedural Worlds? Tell a friend!
  • Need help?

    We work with some of the biggest brands in global gaming, automotive, technology, and government to create environments, games, simulations, and product launches for desktop, mobile, and VR.

    Our unique expertise and technology enable us to deliver solutions that look and run better at a fraction of the time and cost of a typical project.

    Check out some of our non-NDA work in the Gallery, and then Contact Us to accelerate your next project!

  • Create New...